skip to Main Content
Come Cambiare Versione PHP

Come cambiare versione PHP

Come aggiornare la versione PHP

Se hai un sito internet realizzato con un CMS molto probabilmente ti capiterà di dover aggiornare la versione del PHP; seppure non sia un operazione che capita molto spesso di dover fare è utile sapere come destreggiarsi nel caso; facciamo innanzitutto un passo indietro.

Che cos’è il PHP

PHP (acronimo di Personal Home Page) è un linguaggio Open Source (realizzato cioè senza scopi di lucro) che viene utilizzato per diversi scopi, tra i quali spicca la creazione di siti internet; PHP nasce nel 1994 ed è l’alternativa gratuita ad ASP, che è l’ambiente sviluppato da Microsoft.

Il PHP viene costantemente aggiornato, le utime release in ordine cronologico sono state la 5.6 – 7.0 – 7.1 – 7.2 fino ad arrivare all’attuale versione 7.3

Così come avviene per Windows, il supporto alle versioni precedenti ha un tempo limite, ragione per cui è importante effettuare periodicamente un upgrade della versione installata; a dicembre 2018 ad esempio è terminato il supporto per la versione 5.6. Qui di seguito tutte le ultime versioni con la data di fine supporto:

PHP 5.6 data di uscita 28 Agosto 2014 – Fine supporto 31 Dicembre 2018
PHP 7.1 data di uscita 1 Dicembre 2016 – Fine supporto 1 Dicembre 2019
PHP 7.2 data di uscita 30 Novembre 2017 – Fine supporto 30 Novembre 2019
PHP 7.3 data di uscita 6 Dicembre 2018 – Fine supporto 6 Dicembre 2021

Sostanzialmente è buona cosa aggiornare la versione php per diversi motivi:

  • Sicurezza: le vecchie versioni non sono più supportate
  • Velocità: ogni nuova versione PHP è più veloce della precedente
  • Tecnologia: ogni nuova versione PHP contiene delle migliorie

Quali CMS funzionano con il PHP

Ad oggi esistono numerosissimi CMS che si avvalgono del PHP, questi i più conosciuti (ed utilizzati)

  • WordPress
  • Joomla
  • Typo3
  • Magento
  • Prestashop
  • Drupal
  • Concrete5
  • Grav
  • Contao

Cambiare versione PHP da Cpanel

Per modificare la versione PHP da Cpanel, dopo essersi loggati al proprio pannello basta andare alla voce “Gestione versione PHP”. Il nome potrebbe leggermente variare, potreste trovarvi la scritta in inglese oppure solamente “versione php”.

Una volta cliccato sul bottone basterà selezionare la versione PHP che vogliamo e salvare. Tutto qui, non c’è altro da fare

Cambiare versione PHP con Aruba

Se non avete il CPanel ma utilizzate Aruba seguite questa procedura:

Collegarsi a www.aruba.it e cliccare sul bottone arancione “Area Clienti”, successivamente cliccare sull’altro bottone “Area Clienti” presente sulla sinistra

Una volta loggati cliccare su “Pannello di controllo” a fianco del dominio per il quale volete modificare la versione del PHP

A questo punto andate su Hosting Linux – Strumenti e impostazioni

Clicchiamo ora su “Scelta della versione PHP”

Appariranno tutte le versioni PHP disponibili per quell’hosting. Selezioniamo la versione PHP desiderata e clicchiamo su ok.

Attenzione – Alcuni hosting di Aruba (specie quelli più vecchi) hanno la possibilità di selezionare la versione PHP fino alla 7, massimo 7.1 . In quel caso basta aprire un ticket e richiedere l’upgrade alla 7.2 . Il vostro hosting verrà spostato su un server più nuovo provvisto della versione PHP più aggiornata.

Cambiare versione PHP con Tophost

Per chi possiede Tophost, la procedura è ancora più veloce. Dopo essersi loggati al pannello di controllo, cliccare sulla voce “Configurazione PHP”

A questo punto selezionare la nuova versione PHP e cliccare su “Imposta”

Attenzione – La versione più economica ti Tophost attualmente non ha il PHP 7.2 . Se avete questo hosting e volete la versione PHP più aggiornata dovete passare al piano “Topweb Plus”.

Cosa controllare prima di modificare la versione PHP

Prima di cambiare la versione PHP del nostro hosting assicuriamoci che la nuova sia supportata dal nostro CMS; nel caso di wordpress è opportuno controllare che il tema ed il plugin siano pienamente compabili con la nuova versione scelta; potrebbe essere necessario effettuare un aggiornamento di qualche componente per rendere il tutto pienamente compatibile; nel caso abbiate bisogno di supporto potete contattare il nostro team. Saremo lieti di aiutarvi.

error: Content is protected !!
Back To Top